您好,欢迎访问本站博客!登录后台查看权限
  • 欢迎大神光临
  • 有朋自远方来 不亦悦乎

Ubuntu安装Qt出错处理

码叔笔记 dz2015 2017-09-08 358 次浏览 0个评论


安装后编译工程出错:

:-1: error: cannot find -lGL
:-1: error: collect2: error: ld returned 1 exit status

解决办法

sudo apt-get install libgl1-mesa-dev

安装后启动Qt creator出现错误对话框:

/home/codbo/soft/Qt5.4.2/Tools/QtCreator/lib/qtcreator/plugins/libHelp.so: 
无法加载库/home/codbo/soft/Qt5.4.2/Tools/QtCreator/lib/qtcreator/plugins/libHelp.so:
(libgstreamer-0.10.so.0: 无法打开共享对象文件: 没有那个文件或目录)

解决办法

查找这个so文件依赖是哪个库

$ apt-file search libgstreamer-0.10.so.0

然后安装对应的库

$ sudo apt-get install libgstreamer0.10-0

附:

Qt各个版本下载地址:

http://download.qt.io/archive/qt/

http://ftp.vim.org/languages/qt/archive/qt/5.4/


 

已有 358 位网友参与,快来吐槽:

发表评论